PIM background jobs stalling

  • Updated

 

We wanted to inform you that we are currently investigating an issue causing our background PIM jobs to stall. As a result, some jobs are remaining in the queue for an extended period of time.

Our team is actively working on identifying the root cause and implementing a resolution as quickly as possible. We’ll keep you updated on our progress and will notify you as soon as the issue is resolved.

Thank you for your patience and understanding.

Reported Version

PIM

Cause

We've identified a backend bug affecting the Import Asset feature in PIM. In rare cases, jobs with the Overwrite Files option enabled can get stuck and impact overall performance. This is currently limited to a few clients but may affect others due to resource usage. 

The issue does not occur for all customers or asset imports. It only arises when both of the following conditions are met:

  1. The asset import is run with the Overwrite Files option enabled.
  2. The existing assets in the database have a null value in the InternalFileName field (this field is nullable).

We’re testing a hotfix and will provide updates as soon as more information becomes available. Thank you for your patience and understanding. 

 

Workaround

N\A

Resolutions will be posted below. Please use the Follow button to receive status updates.

The fix has been released, and we're actively monitoring PIM today to ensure everything is working as expected in production.